Incorrect Authorization Affecting network-manager package, versions <1.54.3-2ubuntu3.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.24% (15th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-NETWORKMANAGER-19383484
  • published21 Sept 2026
  • disclosed24 Aug 2026

Introduced: 24 Aug 2026

CVE-2026-19685  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 network-manager to version 1.54.3-2ubuntu3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream network-manager package and not the network-manager package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

NetworkManager did not apply the private_user restriction to the 802-1x.ca-path and phase2-ca-path directory-valued connection properties. This incomplete fix for CVE-2025-9615 allows an unprivileged local user to point a private WPA-Enterprise (802.1X) connection profile's CA path at an attacker-controlled directory, bypassing server certificate validation and enabling credential theft via a rogue access point.

CVSS Base Scores

version 3.1