CVE-2026-12245 Affecting nsd package, versions <4.14.0-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.46% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-NSD-17486745
  • published25 Jun 2026
  • disclosed25 Jun 2026

Introduced: 25 Jun 2026

CVE-2026-12245  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 nsd to version 4.14.0-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nsd package and not the nsd package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

NSD from version 4.13.0 has a heap use-after-free bug in logging errors on TLS connections, causing a crash of the server process, which can be triggered trivially by sending a DNS query over a DoT connection, and closing the connection without reading the response.

CVSS Base Scores

version 3.1