CVE-2026-12490 Affecting nsd package, versions <4.14.0-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.22% (11th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-NSD-17486748
  • published25 Jun 2026
  • disclosed25 Jun 2026

Introduced: 25 Jun 2026

CVE-2026-12490  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 nsd to version 4.14.0-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nsd package and not the nsd package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

When a provide-xfr is given with a tls-auth-name, a secondary requesting a transfer should provide a client certificate with that name. However, no client certificate is needed when the request comes in over TLS over the regular tls-port (and not the tls-auth-port) or over over TCP over the regular port, when the other conditions of the provide-xfr rule match.

CVSS Base Scores

version 3.1