Directory Traversal Affecting opam package, versions <2.5.0-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.21% (11th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-OPAM-16238416
  • published24 Apr 2026
  • disclosed16 Apr 2026

Introduced: 16 Apr 2026

CVE-2026-41082  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 opam to version 2.5.0-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opam package and not the opam package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

In OCaml opam before 2.5.1, a .install field containing a destination filepath can use ../ to reach a parent directory.

CVSS Base Scores

version 3.1