Use of Externally-Controlled Format String Affecting rrdtool package, versions <1.7.2-3ubuntu5


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
10.59% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-RRDTOOL-16199562
  • published24 Apr 2026
  • disclosed4 Jan 2015

Introduced: 4 Jan 2015

CVE-2013-2131  (opens in a new tab)
CWE-134  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 rrdtool to version 1.7.2-3ubuntu5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rrdtool package and not the rrdtool package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

Format string vulnerability in the rrdtool module 1.4.7 for Python, as used in Zenoss, allows context-dependent attackers to cause a denial of service (crash) via format string specifiers to the rrdtool.graph function.

CVSS Base Scores

version 3.1