Cross-site Scripting (XSS) Affecting sogo package, versions <5.12.4-1.2ubuntu0.1~esm1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.45% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-SOGO-16235939
  • published30 Jun 2026
  • disclosed24 Feb 2026

Introduced: 24 Feb 2026

CVE-2026-3054  (opens in a new tab)
CWE-79  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 sogo to version 5.12.4-1.2ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sogo package and not the sogo package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

A vulnerability was identified in Alinto SOGo 5.12.3/5.12.4. This impacts an unknown function. The manipulation of the argument hint leads to cross site scripting. The attack can be initiated remotely. The exploit is publicly available and might be used. The vendor was contacted early about this disclosure but did not respond in any way.

CVSS Base Scores

version 3.1