CVE-2025-67269 Affecting gpsd package, versions <3.27-1.1ubuntu1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.56% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2610-GPSD-21216534
  • published18 Oct 2026
  • disclosed2 Jan 2026

Introduced: 2 Jan 2026

CVE-2025-67269  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.10 gpsd to version 3.27-1.1ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gpsd package and not the gpsd package as distributed by Ubuntu. See How to fix? for Ubuntu:26.10 relevant fixed versions and status.

An integer underflow vulnerability exists in the nextstate() function in gpsd/packet.c of gpsd versions prior to commit ffa1d6f40bca0b035fc7f5e563160ebb67199da7. When parsing a NAVCOM packet, the payload length is calculated using lexer-&gt;length = (size_t)c - 4 without checking if the input byte c is less than 4. This results in an unsigned integer underflow, setting lexer-&gt;length to a very large value (near SIZE_MAX). The parser then enters a loop attempting to consume this massive number of bytes, causing 100% CPU utilization and a Denial of Service (DoS) condition.

CVSS Base Scores

version 3.1