CVE-2025-67268 Affecting gpsd package, versions <3.27-1.1ubuntu1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.79% (55th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2610-GPSD-21218795
  • published18 Oct 2026
  • disclosed2 Jan 2026

Introduced: 2 Jan 2026

CVE-2025-67268  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.10 gpsd to version 3.27-1.1ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gpsd package and not the gpsd package as distributed by Ubuntu. See How to fix? for Ubuntu:26.10 relevant fixed versions and status.

gpsd before commit dc966aa contains a heap-based out-of-bounds write vulnerability in the drivers/driver_nmea2000.c file. The hnd_129540 function, which handles NMEA2000 PGN 129540 (GNSS Satellites in View) packets, fails to validate the user-supplied satellite count against the size of the skyview array (184 elements). This allows an attacker to write beyond the bounds of the array by providing a satellite count up to 255, leading to memory corruption, Denial of Service (DoS), and potentially arbitrary code execution.

CVSS Base Scores

version 3.1