CVE-2021-33516 Affecting gupnp package, versions <1.2.4-1ubuntu1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.08% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2610-GUPNP-21197112
  • published18 Oct 2026
  • disclosed24 May 2021

Introduced: 24 May 2021

CVE-2021-33516  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.10 gupnp to version 1.2.4-1ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gupnp package and not the gupnp package as distributed by Ubuntu. See How to fix? for Ubuntu:26.10 relevant fixed versions and status.

An issue was discovered in GUPnP before 1.0.7 and 1.1.x and 1.2.x before 1.2.5. It allows DNS rebinding. A remote web server can exploit this vulnerability to trick a victim's browser into triggering actions against local UPnP services implemented using this library. Depending on the affected service, this could be used for data exfiltration, data tempering, etc.

CVSS Base Scores

version 3.1