Out-of-Bounds Affecting hdf5 package, versions *


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.26% (18th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2610-HDF5-21207861
  • published18 Oct 2026
  • disclosed19 Jun 2025

Introduced: 19 Jun 2025

CVE-2025-6269  (opens in a new tab)
CWE-119  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:26.10 hdf5.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hdf5 package and not the hdf5 package as distributed by Ubuntu. See How to fix? for Ubuntu:26.10 relevant fixed versions and status.

A vulnerability classified as critical was found in HDF5 up to 1.14.6. Affected by this vulnerability is the function H5C__reconstruct_cache_entry of the file H5Cimage.c. The manipulation leads to heap-based buffer overflow. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used.

CVSS Base Scores

version 3.1