Integer Overflow or Wraparound Affecting libgsf package, versions <1.14.52-1ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.4% (33rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2610-LIBGSF-21212179
  • published18 Oct 2026
  • disclosed3 Oct 2024

Introduced: 3 Oct 2024

CVE-2024-36474  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.10 libgsf to version 1.14.52-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgsf package and not the libgsf package as distributed by Ubuntu. See How to fix? for Ubuntu:26.10 relevant fixed versions and status.

An integer overflow vulnerability exists in the Compound Document Binary File format parser of the GNOME Project G Structured File Library (libgsf) version v1.14.52. A specially crafted file can result in an integer overflow when processing the directory from the file that allows for an out-of-bounds index to be used when reading and writing to an array. This can lead to arbitrary code execution. An attacker can provide a malicious file to trigger this vulnerability.

CVSS Base Scores

version 3.1