Heap-based Buffer Overflow Affecting libxrender package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.26% (18th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2610-LIBXRENDER-21240791
  • published18 Oct 2026
  • disclosed21 Sept 2026

Introduced: 21 Sep 2026

CVE-2026-88807  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:26.10 libxrender.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxrender package and not the libxrender package as distributed by Ubuntu. See How to fix? for Ubuntu:26.10 relevant fixed versions and status.

A heap overflow in libXrender before 0.9.13 in RenderQueryPictFormats could be used by malicious X servers to inject code into attached X clients.

CVSS Base Scores

version 3.1