Incorrect Default Permissions Affecting nfs-utils package, versions <1:1.3.4-2.5ubuntu5


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.52% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2610-NFSUTILS-21190323
  • published18 Oct 2026
  • disclosed19 Sept 2019

Introduced: 19 Sep 2019

CVE-2019-3689  (opens in a new tab)
CWE-276  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.10 nfs-utils to version 1:1.3.4-2.5ubuntu5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nfs-utils package and not the nfs-utils package as distributed by Ubuntu. See How to fix? for Ubuntu:26.10 relevant fixed versions and status.

The nfs-utils package in SUSE Linux Enterprise Server 12 before and including version 1.3.0-34.18.1 and in SUSE Linux Enterprise Server 15 before and including version 2.1.1-6.10.2 the directory /var/lib/nfs is owned by statd:nogroup. This directory contains files owned and managed by root. If statd is compromised, it can therefore trick processes running with root privileges into creating/overwriting files anywhere on the system.

CVSS Base Scores

version 3.1