HTTP Request Smuggling Affecting python-eventlet package, versions <0.39.0-0ubuntu2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.42% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2610-PYTHONEVENTLET-21216623
  • published18 Oct 2026
  • disclosed29 Aug 2025

Introduced: 29 Aug 2025

CVE-2025-58068  (opens in a new tab)
CWE-444  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.10 python-eventlet to version 0.39.0-0ubuntu2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-eventlet package and not the python-eventlet package as distributed by Ubuntu. See How to fix? for Ubuntu:26.10 relevant fixed versions and status.

Eventlet is a concurrent networking library for Python. Prior to version 0.40.3, the Eventlet WSGI parser is vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer sections. This vulnerability could enable attackers to, bypass front-end security controls, launch targeted attacks against active site users, and poison web caches. This problem has been patched in Eventlet 0.40.3 by dropping trailers which is a breaking change if a backend behind eventlet.wsgi proxy requires trailers. A workaround involves not using eventlet.wsgi facing untrusted clients.

CVSS Base Scores

version 3.1