Improper Handling of Highly Compressed Data (Data Amplification) Affecting python-tornado package, versions <6.5.5-5ubuntu1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.63% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2610-PYTHONTORNADO-21219225
  • published18 Oct 2026
  • disclosed1 Oct 2026

Introduced: 1 Oct 2026

NewCVE-2026-103262  (opens in a new tab)
CWE-409  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.10 python-tornado to version 6.5.5-5ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-tornado package and not the python-tornado package as distributed by Ubuntu. See How to fix? for Ubuntu:26.10 relevant fixed versions and status.

Tornado versions before 6.5.9 contain an unbounded memory accumulation vulnerability in CurlAsyncHTTPClient that allows remote attackers to cause denial of service by sending a compressed response. Attackers can send a gzip-encoded decompression bomb that accumulates in memory without size limits, causing the application process to be killed by out-of-memory conditions.

CVSS Base Scores

version 3.1