CVE-2026-3888 Affecting snapd package, versions <2.74.1+ubuntu26.04.3


Severity

Recommended
high

Based on Ubuntu security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
1.38% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2610-SNAPD-21227354
  • published18 Oct 2026
  • disclosed17 Mar 2026

Introduced: 17 Mar 2026

CVE-2026-3888  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.10 snapd to version 2.74.1+ubuntu26.04.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream snapd package and not the snapd package as distributed by Ubuntu. See How to fix? for Ubuntu:26.10 relevant fixed versions and status.

Local privilege escalation in snapd on Linux allows local attackers to get root privilege by re-creating snap's private /tmp directory when systemd-tmpfiles is configured to automatically clean up this directory. This issue affects Ubuntu 16.04 LTS, 18.04 LTS, 20.04 LTS, 22.04 LTS, and 24.04 LTS.