Improper Encoding or Escaping of Output Affecting swish-e package, versions *


Severity

Recommended
high

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.95% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2610-SWISHE-21200659
  • published18 Oct 2026
  • disclosed16 Feb 2022

Introduced: 16 Feb 2022

CVE-2022-25235  (opens in a new tab)
CWE-116  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:26.10 swish-e.

NVD Description

Note: Versions mentioned in the description apply only to the upstream swish-e package and not the swish-e package as distributed by Ubuntu. See How to fix? for Ubuntu:26.10 relevant fixed versions and status.

xmltok_impl.c in Expat (aka libexpat) before 2.4.5 lacks certain validation of encoding, such as checks for whether a UTF-8 character is valid in a certain context.

CVSS Base Scores

version 3.1