Improper Certificate Validation Affecting wlc package, versions *


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.15% (4th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2610-WLC-21222332
  • published18 Oct 2026
  • disclosed12 Jan 2026

Introduced: 12 Jan 2026

CVE-2026-22250  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:26.10 wlc.

NVD Description

Note: Versions mentioned in the description apply only to the upstream wlc package and not the wlc package as distributed by Ubuntu. See How to fix? for Ubuntu:26.10 relevant fixed versions and status.

wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.0, the SSL verification would be skipped for some crafted URLs. This vulnerability is fixed in 1.17.0.

CVSS Base Scores

version 3.1