Improper Authentication The advisory has been revoked - it doesn't affect any version of package nodebb/nodebb  (opens in a new tab)


Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
2.43% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Improper Authentication vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-NODEBBNODEBB-2366470
  • published26 Jan 2022
  • disclosed20 Aug 2020
  • creditUnknown

Introduced: 20 Aug 2020

CVE-2020-15149  (opens in a new tab)
CWE-287  (opens in a new tab)

Amendment

This was deemed not a vulnerability.

Overview

Affected versions of this package are vulnerable to Improper Authentication. NodeBB before version 1.14.3 has a bug introduced in version 1.12.2 in the validation logic that makes it possible to change the password of any user on a running NodeBB forum by sending a specially crafted socket.io call to the server. This could lead to a privilege escalation event due via an account takeover. As a workaround you may cherry-pick the following commit from the project's repository to your running instance of NodeBB: 16cee1b03ba3eee177834a1fdac4aa8a12b39d2a. This is fixed in version 1.14.3.