CVE-2026-97031 Affecting bank-vaults package, versions <1.33.2-r5


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.52% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-BANKVAULTS-20732606
  • published10 Oct 2026
  • disclosed8 Oct 2026

Introduced: 8 Oct 2026

NewCVE-2026-97031  (opens in a new tab)

How to fix?

Upgrade Wolfi bank-vaults to version 1.33.2-r5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream bank-vaults package and not the bank-vaults package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

Multiple ECH outer extension references are not permitted under RFC 9849; previously, a client could send a well-crafted packet that could trigger memory exhaustion in the server process by specifying multiple references. We now reject these as malformed and curb the memory amplification vector as a result.

CVSS Base Scores

version 3.1