Out-of-bounds Write Affecting giflib package, versions <6.1.2-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.44% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-GIFLIB-15461120
  • published11 Mar 2026
  • disclosed30 Sept 2024

Introduced: 30 Sep 2024

CVE-2024-45993  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Wolfi giflib to version 6.1.2-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream giflib package and not the giflib package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

Giflib Project v5.2.2 is vulnerable to a heap buffer overflow via gif2rgb.

CVSS Base Scores

version 3.1