CVE-2025-22868 Affecting git-credential-oauth package, versions <0.15.0-r1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.87% (57th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-GITCREDENTIALOAUTH-15386331
  • published4 Mar 2026
  • disclosed26 Feb 2025

Introduced: 26 Feb 2025

CVE-2025-22868  (opens in a new tab)

How to fix?

Upgrade Wolfi git-credential-oauth to version 0.15.0-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream git-credential-oauth package and not the git-credential-oauth package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

An attacker can pass a malicious malformed token which causes unexpected memory to be consumed during parsing.

CVSS Base Scores

version 3.1