CVE-2025-61725 Affecting git-credential-oauth package, versions <0.16.0-r1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.65% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-GITCREDENTIALOAUTH-15386372
  • published4 Mar 2026
  • disclosed29 Oct 2025

Introduced: 29 Oct 2025

CVE-2025-61725  (opens in a new tab)

How to fix?

Upgrade Wolfi git-credential-oauth to version 0.16.0-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream git-credential-oauth package and not the git-credential-oauth package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

The ParseAddress function constructs domain-literal address components through repeated string concatenation. When parsing large domain-literal components, this can cause excessive CPU consumption.

CVSS Base Scores

version 3.1