Integer Overflow or Wraparound Affecting gitlab-runner-19.3 package, versions <19.3.5-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
1.31% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-GITLABRUNNER193-21828824
  • published29 Oct 2026
  • disclosed22 Oct 2026

Introduced: 22 Oct 2026

NewCVE-2026-110264  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Wolfi gitlab-runner-19.3 to version 19.3.5-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gitlab-runner-19.3 package and not the gitlab-runner-19.3 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

An issue has been discovered in GitLab CE/EE affecting all versions from 7.0 before 18.11.13, 19.0 before 19.0.10, 19.1 before 19.1.9, 19.2 before 19.2.9, 19.3 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server due to integer overflow when compiling a specially crafted regular expression.

CVSS Base Scores

version 3.1