Cross-site Scripting (XSS) Affecting gitlab-runner-19.3 package, versions <19.3.5-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.48% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-GITLABRUNNER193-21828829
  • published29 Oct 2026
  • disclosed13 Oct 2026

Introduced: 13 Oct 2026

NewCVE-2026-92883  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Wolfi gitlab-runner-19.3 to version 19.3.5-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gitlab-runner-19.3 package and not the gitlab-runner-19.3 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.1 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user to execute arbitrary JavaScript in the context of other users' browser sessions via a specially crafted repository, due to improper sanitization of HTML attributes in syntax-highlighted output.