CVE-2026-94440 Affecting http-echo package, versions <1.0.0-r36


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.51% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-HTTPECHO-20743519
  • published10 Oct 2026
  • disclosed8 Oct 2026

Introduced: 8 Oct 2026

NewCVE-2026-94440  (opens in a new tab)

How to fix?

Upgrade Wolfi http-echo to version 1.0.0-r36 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream http-echo package and not the http-echo package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

Parsing a multipart form can bypass memory limits and read an arbitrarily long line into memory when the remaining limit at the start of a part is less than 400 bytes.

CVSS Base Scores

version 3.1