CVE-2026-97030 Affecting k6 package, versions <2.3.0-r1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.29% (22nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-K6-20744257
  • published10 Oct 2026
  • disclosed8 Oct 2026

Introduced: 8 Oct 2026

NewCVE-2026-97030  (opens in a new tab)

How to fix?

Upgrade Wolfi k6 to version 2.3.0-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream k6 package and not the k6 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

A trusted template author may have previously written a valid template wherein the use of the 'yield' keyword would not be correctly escaped. We now ensure that valid keyword uses are escaped and non-keyword uses are not escaped.

CVSS Base Scores

version 3.1