CVE-2024-44906 Affecting kyverno-policy-reporter package, versions <3.5.0-r1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.39% (32nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-KYVERNOPOLICYREPORTER-15400006
  • published5 Mar 2026
  • disclosed12 Jun 2025

Introduced: 12 Jun 2025

CVE-2024-44906  (opens in a new tab)

How to fix?

Upgrade Wolfi kyverno-policy-reporter to version 3.5.0-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kyverno-policy-reporter package and not the kyverno-policy-reporter package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

uptrace pgdriver v1.2.1 was discovered to contain a SQL injection vulnerability via the appendArg function in /pgdriver/format.go. The maintainer has stated that the issue is fixed in v1.2.15.