Arbitrary Argument Injection Affecting langfuse-3 package, versions <3.225.12-r3


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.71% (53rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-LANGFUSE3-21429949
  • published22 Oct 2026
  • disclosed20 Oct 2026

Introduced: 20 Oct 2026

NewCVE-2026-112944  (opens in a new tab)
CWE-88  (opens in a new tab)

How to fix?

Upgrade Wolfi langfuse-3 to version 3.225.12-r3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream langfuse-3 package and not the langfuse-3 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

launch-editor allows users to open files with line numbers in editor from Node.js. Prior to 2.14.2, when an attacker can create a filesystem entry beginning with plus or minus in the working directory, an affected editor is selected, and the path can remain relative or is converted to a relative WSL path, launchEditor forwards the path without forcing it to be interpreted as a positional filename. Editor option parsing then treats the attacker-controlled filename as a command-line flag, which can cause unintended file overwrite or arbitrary command execution by the selected editor. The affected editors are Vim and gVim, MacVim, Emacs and Emacsclient, and Notepad++ when a plugin exposes dangerous operations; WSL path conversion keeps Vite and newer middleware callers exposed. This issue is fixed in version 2.14.2.

CVSS Base Scores

version 3.1