Information Exposure The advisory has been revoked - it doesn't affect any version of package logstash-9.1  (opens in a new tab)


Threat Intelligence

EPSS
0.56% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-LOGSTASH91-16005007
  • published13 Apr 2026
  • disclosed30 Dec 2025

Introduced: 30 Dec 2025

CVE-2025-61594  (opens in a new tab)
CWE-200  (opens in a new tab)
CWE-212  (opens in a new tab)

Amendment

The Wolfi security team deemed this advisory irrelevant for Wolfi:latest.

NVD Description

Note: Versions mentioned in the description apply only to the upstream logstash-9.1 package and not the logstash-9.1 package as distributed by Wolfi.

URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.