Integer Overflow or Wraparound The advisory has been revoked - it doesn't affect any version of package logstash-9.1  (opens in a new tab)


Threat Intelligence

EPSS
0.38% (32nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-LOGSTASH91-16879432
  • published26 May 2026
  • disclosed13 May 2026

Introduced: 13 May 2026

CVE-2026-42580  (opens in a new tab)
CWE-190  (opens in a new tab)
CWE-444  (opens in a new tab)

Amendment

The Wolfi security team deemed this advisory irrelevant for Wolfi:latest.

NVD Description

Note: Versions mentioned in the description apply only to the upstream logstash-9.1 package and not the logstash-9.1 package as distributed by Wolfi.

Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, Netty's chunk size parser silently overflows int, enabling request smuggling attacks. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.