CVE-2023-52970 Affecting mariadb-10.11 package, versions <10.11.19-r2


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.46% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-MARIADB1011-15401256
  • published5 Mar 2026
  • disclosed8 Mar 2025

Introduced: 8 Mar 2025

CVE-2023-52970  (opens in a new tab)

How to fix?

Upgrade Wolfi mariadb-10.11 to version 10.11.19-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mariadb-10.11 package and not the mariadb-10.11 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

MariaDB Server 10.4 through 10.5., 10.6 through 10.6., 10.7 through 10.11., 11.0 through 11.0., and 11.1 through 11.4.* crashes in Item_direct_view_ref::derived_field_transformer_for_where.

CVSS Base Scores

version 3.1