CVE-2026-3494 Affecting mariadb-11.8 package, versions <11.8.9-r1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.31% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-MARIADB118-19827878
  • published15 Sept 2026
  • disclosed3 Mar 2026

Introduced: 3 Mar 2026

CVE-2026-3494  (opens in a new tab)

How to fix?

Upgrade Wolfi mariadb-11.8 to version 11.8.9-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mariadb-11.8 package and not the mariadb-11.8 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

In MariaDB server version through 11.8.5, when server audit plugin is enabled with server_audit_events variable configured with QUERY_DCL, QUERY_DDL, or QUERY_DML filtering, if an authenticated database user invokes a SQL statement prefixed with double-hyphen (—) or hash (#) style comments, the statement is not logged.

CVSS Base Scores

version 3.1