CVE-2026-56858 Affecting migrate package, versions <4.19.1-r24


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.31% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-MIGRATE-18828709
  • published15 Aug 2026
  • disclosed13 Aug 2026

Introduced: 13 Aug 2026

CVE-2026-56858  (opens in a new tab)

How to fix?

Upgrade Wolfi migrate to version 4.19.1-r24 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream migrate package and not the migrate package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

Previously, pathological inputs could close an unescaped '/' early, allowing for attack-controlled data to inject arbitrary content, potentially leading to XSS.

CVSS Base Scores

version 3.1