Improper Certificate Validation Affecting opa-envoy package, versions <1.11.0-r1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.28% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-OPAENVOY-15405419
  • published5 Mar 2026
  • disclosed3 Dec 2025

Introduced: 3 Dec 2025

CVE-2025-61727  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

Upgrade Wolfi opa-envoy to version 1.11.0-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opa-envoy package and not the opa-envoy package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

An excluded subdomain constraint in a certificate chain does not restrict the usage of wildcard SANs in the leaf certificate. For example a constraint that excludes the subdomain test.example.com does not prevent a leaf certificate from claiming the SAN *.example.com.

CVSS Base Scores

version 3.1