CVE-2026-14666 Affecting postgresql-17 package, versions <17.11-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.21% (12th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-POSTGRESQL17-21779113
  • published29 Oct 2026
  • disclosed13 Aug 2026

Introduced: 13 Aug 2026

CVE-2026-14666  (opens in a new tab)

How to fix?

Upgrade Wolfi postgresql-17 to version 17.11-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream postgresql-17 package and not the postgresql-17 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

Incomplete tracking in PostgreSQL of changes to role membership, role attributes, and database ownership allows a query to continue using cached row-level security policies after those changes require a different policy, via plan reuse. Stale policies continue until some other event invalidates the cache or connection termination ends the session. This permits a user to complete reads and modifications that were recently permitted but now forbidden. An attacker must tailor an attack to a particular application's pattern of privilege removal and role-specific row security policies. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

CVSS Base Scores

version 3.1