CVE-2026-14668 Affecting postgresql-17 package, versions <17.11-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.33% (26th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-POSTGRESQL17-21779246
  • published29 Oct 2026
  • disclosed13 Aug 2026

Introduced: 13 Aug 2026

CVE-2026-14668  (opens in a new tab)

How to fix?

Upgrade Wolfi postgresql-17 to version 17.11-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream postgresql-17 package and not the postgresql-17 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

Type confusion regarding input of PostgreSQL ctid data type selectivity estimator allows an object creator to view a calculation derived from the value of an arbitrary 4-byte span of memory, via a chosen non-ctid input. While the calculation loses precision, substantial memory value recovery appears possible. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

CVSS Base Scores

version 3.1