CVE-2026-15741 Affecting postgresql-18 package, versions <18.6-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.44% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-POSTGRESQL18-21779272
  • published29 Oct 2026
  • disclosed13 Aug 2026

Introduced: 13 Aug 2026

CVE-2026-15741  (opens in a new tab)

How to fix?

Upgrade Wolfi postgresql-18 to version 18.6-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream postgresql-18 package and not the postgresql-18 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

SQL injection in PostgreSQL EXTRACT() deparse allows an object owner to execute arbitrary SQL as a superuser via a hostile object definition. Attacks affect expression deparse consumers broadly, including pg_dump, psql commands like \sf, and any similar usage in non-core tools. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

CVSS Base Scores

version 3.1