CVE-2026-14672 Affecting postgresql-18 package, versions <18.6-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.39% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-POSTGRESQL18-21779344
  • published29 Oct 2026
  • disclosed13 Aug 2026

Introduced: 13 Aug 2026

CVE-2026-14672  (opens in a new tab)

How to fix?

Upgrade Wolfi postgresql-18 to version 18.6-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream postgresql-18 package and not the postgresql-18 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

Observable response discrepancy in PostgreSQL SCRAM authentication allows an unauthenticated user to test the existence of a user via observing the SCRAM iteration count. This requires the probed user to have a non-default scram_iterations count, because the authentication challenge for a nonexistent user reports the default scram_iterations. Within major versions 16-18, minor versions before PostgreSQL 18.6, 17.11, and 16.15 are affected. Versions before PostgreSQL 16 are unaffected.

CVSS Base Scores

version 3.1