Integer Overflow or Wraparound Affecting ruby-3.3 package, versions <3.3.12-r10


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
18.43% (98th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-RUBY33-21692389
  • published24 Oct 2026
  • disclosed13 Oct 2026

Introduced: 13 Oct 2026

NewCVE-2026-97229  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Wolfi ruby-3.3 to version 3.3.12-r10 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-3.3 package and not the ruby-3.3 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.