Information Exposure Affecting ruby3.3-oauth2 package, versions <2.0.22-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.45% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-RUBY33OAUTH2-18741233
  • published13 Aug 2026
  • disclosed28 Jul 2026

Introduced: 28 Jul 2026

CVE-2026-54603  (opens in a new tab)
CWE-200  (opens in a new tab)
CWE-601  (opens in a new tab)

How to fix?

Upgrade Wolfi ruby3.3-oauth2 to version 2.0.22-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby3.3-oauth2 package and not the ruby3.3-oauth2 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

OAuth2 is a Ruby wrapper for the OAuth 2.0 and 2.1 authorization frameworks, including OpenID Connect (OIDC). From 0.4.0 to 2.0.21, a protocol-relative redirect Location returned to OAuth2::Client#request overrides the request authority, so the bearer Authorization header is sent to an attacker-controlled host, leaking the credential. This issue is fixed in version 2.0.22.