Interpretation Conflict The advisory has been revoked - it doesn't affect any version of package ruby3.4-rails-8.0  (opens in a new tab)


Threat Intelligence

EPSS
0.26% (19th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-RUBY34RAILS80-16005919
  • published13 Apr 2026
  • disclosed2 Apr 2026

Introduced: 2 Apr 2026

CVE-2026-26961  (opens in a new tab)
CWE-436  (opens in a new tab)

Amendment

The Wolfi security team deemed this advisory irrelevant for Wolfi:latest.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby3.4-rails-8.0 package and not the ruby3.4-rails-8.0 package as distributed by Wolfi.

Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Multipart::Parser extracts the boundary parameter from multipart/form-data using a greedy regular expression. When a Content-Type header contains multiple boundary parameters, Rack selects the last one rather than the first. In deployments where an upstream proxy, WAF, or intermediary interprets the first boundary parameter, this mismatch can allow an attacker to smuggle multipart content past upstream inspection and have Rack parse a different body structure than the intermediary validated. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.