Resource Exhaustion The advisory has been revoked - it doesn't affect any version of package ruby3.4-rails-8.0  (opens in a new tab)


Threat Intelligence

EPSS
0.45% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-RUBY34RAILS80-16005935
  • published13 Apr 2026
  • disclosed2 Apr 2026

Introduced: 2 Apr 2026

CVE-2026-34230  (opens in a new tab)
CWE-400  (opens in a new tab)
CWE-407  (opens in a new tab)

Amendment

The Wolfi security team deemed this advisory irrelevant for Wolfi:latest.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby3.4-rails-8.0 package and not the ruby3.4-rails-8.0 package as distributed by Wolfi.

Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Utils.select_best_encoding processes Accept-Encoding values with quadratic time complexity when the header contains many wildcard (*) entries. Because this method is used by Rack::Deflater to choose a response encoding, an unauthenticated attacker can send a single request with a crafted Accept-Encoding header and cause disproportionate CPU consumption on the compression middleware path. This results in a denial of service condition for applications using Rack::Deflater. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.