Integer Overflow or Wraparound Affecting ruby-4.0 package, versions <4.0.7-r6


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
1% (63rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-RUBY40-21692390
  • published24 Oct 2026
  • disclosed22 Oct 2026

Introduced: 22 Oct 2026

NewCVE-2026-110264  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Wolfi ruby-4.0 to version 4.0.7-r6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-4.0 package and not the ruby-4.0 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

An issue has been discovered in GitLab CE/EE affecting all versions from 7.0 before 18.11.13, 19.0 before 19.0.10, 19.1 before 19.1.9, 19.2 before 19.2.9, 19.3 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server due to integer overflow when compiling a specially crafted regular expression.