CVE-2026-33818 Affecting tfsec package, versions <1.28.14-r44


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.57% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-TFSEC-18797889
  • published15 Aug 2026
  • disclosed13 Aug 2026

Introduced: 13 Aug 2026

CVE-2026-33818  (opens in a new tab)

How to fix?

Upgrade Wolfi tfsec to version 1.28.14-r44 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tfsec package and not the tfsec package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

Enforce a recursion limit in Unmarshal to prevent stack exhaustion when parsing deeply-nested, recursive structures.

CVSS Base Scores

version 3.1