Uncontrolled Recursion Affecting velero package, versions <1.18.4-r6


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.29% (22nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-VELERO-22083388
  • published31 Oct 2026
  • disclosed26 Oct 2026

Introduced: 26 Oct 2026

NewCVE-2026-116586  (opens in a new tab)
CWE-674  (opens in a new tab)

How to fix?

Upgrade Wolfi velero to version 1.18.4-r6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream velero package and not the velero package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

Go JOSE provides an implementation of the Javascript Object Signing and Encryption set of standards in Go, including support for JSON Web Encryption (JWE), JSON Web Signature (JWS), and JSON Web Token (JWT) standards. Prior to 4.1.5, parsing attacker-controlled JSON through go-jose allows deeply nested arrays or objects to exceed Go's stack limit. The resulting stack overflow crashes the application and permits denial of service in applications that parse untrusted JSON through go-jose. This issue is fixed in version 4.1.5.

CVSS Base Scores

version 3.1