smarty/smarty vulnerabilities

Smarty - the compiling PHP template engine

Direct Vulnerabilities

Known vulnerabilities in the smarty/smarty package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Cross-site Scripting (XSS)

<3.1.47 >=4.0.0, <4.2.1
  • H
Arbitrary Code Injection

<3.1.45 >=4.0.0, <4.1.1
  • H
Improper Input Validation

<3.1.43 >=4.0.0, <4.0.3
  • M
Remote Code Execution (RCE)

<3.1.42 >=4.0.0, <4.0.2
  • C
Arbitrary Code Injection

<3.1.39
  • H
Sandbox Bypass

<3.1.39
  • M
Directory Traversal

<3.1.33
  • H
Directory Traversal

<3.1.33
  • M
Directory Traversal

<3.1.33
  • C
Arbitrary Code Injection

<3.1.32