Arbitrary Code Injection Affecting smarty/smarty Open this link in a new tab package, versions <3.1.45 >=4.0.0, <4.1.1


0.0
high
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PHP-SMARTYSMARTY-2847867

  • published

    25 May 2022

  • disclosed

    25 May 2022

  • credit

    altm4n

How to fix?

Upgrade smarty/smarty to version 3.1.45, 4.1.1 or higher.

Overview

Affected versions of this package are vulnerable to Arbitrary Code Injection. Template authors can inject php code by choosing a malicious {block} name or {include} file name.