gnutls28 vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the gnutls28 package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • L
Information Exposure

*
  • L
Uncaught Exception

*
  • L
Information Exposure

*
  • L
Improper Verification of Cryptographic Signature

*
  • M
Information Exposure

<3.7.1-5+deb11u4
  • H
Information Exposure

<3.7.1-5+deb11u3
  • H
Double Free

<3.7.1-5+deb11u2
  • M
NULL Pointer Dereference

<3.7.1-5+deb11u1
  • C
Use After Free

<3.7.1-1
  • C
Use After Free

<3.7.1-1
  • H
Out-of-bounds Write

<3.6.15-1
  • H
Use of a Broken or Risky Cryptographic Algorithm

<3.6.14-1
  • H
Use of a Broken or Risky Cryptographic Algorithm

<3.6.13-2
  • H
Access of Uninitialized Pointer

<3.6.7-2
  • H
Double Free

<3.6.7-2
  • M
Information Exposure

<3.6.5-2
  • M
Use of a Broken or Risky Cryptographic Algorithm

<3.5.19-1
  • M
Use of a Broken or Risky Cryptographic Algorithm

<3.5.19-1
  • M
Use of a Broken or Risky Cryptographic Algorithm

<3.5.19-1
  • H
Improper Certificate Validation

<3.3.8-6
  • H
Improper Input Validation

<3.4.13-1
  • H
NULL Pointer Dereference

<3.5.8-6
  • H
Out-of-bounds Write

<3.5.8-4
  • C
Out-of-Bounds

<3.5.8-1
  • H
Out-of-bounds Read

<3.5.8-1
  • C
Out-of-Bounds

<3.5.8-1
  • C
Double Free

<3.5.8-1
  • H
Access Restriction Bypass

<3.5.3-4
  • M
Improper Data Handling

<3.3.15-1
  • H
CVE-2015-3308

<3.3.8-7
  • M
CVE-2015-6251

<3.3.17-1
  • M
Cryptographic Issues

<3.3.8-4
  • L
Cryptographic Issues

<3.3.8-5
  • M
CVE-2014-3465

<3.2.10-1
  • M
Out-of-Bounds

<3.2.15-1
  • M
Access Restriction Bypass

<3.2.11-1
  • M
Cryptographic Issues

<3.2.11-2
  • L
Cryptographic Issues

<3.0.22-3
  • M
Cryptographic Issues

<3.0.22-3
  • H
Cryptographic Issues

<3.0.17-2
  • H
Resource Management Errors

<3.0.14-1
  • M
Cryptographic Issues

<3.0.11-1
  • L
Improper Input Validation

*