org.apache.kafka:generator@2.8.1 vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the org.apache.kafka:generator package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Memory Allocation with Excessive Size Value

Affected versions of this package are vulnerable to Memory Allocation with Excessive Size Value which allows a malicious unauthenticated client to allocate large amounts of memory on brokers.

Note:

  1. This vulnerability was actually fixed in 3.2.2, but due to an unrelated major bug in this release, we recommend users upgrade to 3.2.3.

  2. The fixed code exists in two components, which means that clients and generator were both affected.

How to fix Memory Allocation with Excessive Size Value?

Upgrade org.apache.kafka:generator to version 2.8.2, 3.0.2, 3.1.2, 3.2.3 or higher.

[2.8.0,2.8.2) [3.0.0,3.0.2) [3.1.0,3.1.2) [3.2.0,3.2.3)